Use of 3D connexion settings

Post your question or observations here.

Moderator: DevRuss

Post Reply
Chrismn
Posts: 2
Joined: Wed Oct 16, 2019 12:10 pm

Use of 3D connexion settings

Post by Chrismn » Wed Oct 16, 2019 12:29 pm

Hi

New user; just received my 3D Connexions Spacemouse Pro - bought exclusively for use in E:D with ControlmyJoystick

First test flight was a revelation.. I have a Logitech X56 Hotas - so the 3D mouse was all about that third lateral axis, and getting a more precise response than the thumbsticks on the Hotas.

Binding the axes was simple (relatively) and I love the curve control - the response in flight was amazing - really happy.

But - I just could not get to grips with assigning buttons.. at all. Eventually - I realised that in the 3D Connexions setting, I could assign shortcuts.. such that the shift button could simply output "5" or whatever - and binding "5" to a function in game had the right result.

On logging in again - the buttons work (persistent in the 3D settings) - but none of the axes... I can see the inputs, and I can see that the curves are working, and I can see that outputs are targeted correctly to the right application (in fact I cannot switch to the CMK window without it immediately flicking back - maybe I've got the curves up too much) - but no Axes..

I reset all sources. I re-bound the axes in game (using the same method as I had done the day previously) - no joy.

Plus - I cannot bind any macro to any of the 3D mouse buttons.. in fact the only way I can bind anything is to connect to the X56 Rhino throttle, and bind to a button on that - though curiously - I cannot get the Rhino Stick to show any axes input.

I've no doubt that CMJ is incredibly capable.. but I'm really caught on the basics..

My next move is to reset the mouse to default, and import a profile.. see if I can make sense from there.. but I'm very confused about button binding cause I can't seem to show the activation of any of the mouse buttons within the CMJ software.. no - that's not true.. while I'm trying to bind - say button 1 on the mouse, an overlay will pop up, showing button 1 is pressed - but even then it's not being captured in the binding dialog window..

I'm absolutely convinced that the hardware is ideal (it really feels authentic to me, in the sense that this is how I would design a flight control system for a spaceship..) but right now I'm thinking that I could simple use the 3D connexions "speed" setting to make the hardware useable and bind directly..

Will update if I have a more positive experience next session..
Chris

Post Reply